Wren Sound Systems, LLC

 

Wren V5US FAQs

RegisterCompatibilityFAQsGuarantee & WarrantyDocsSupport

Wren Sound Systems FAQs/troubleshooting tips

Scroll through the tabs below for answers to common queries.

If you need further assistance, feel free to contact our technical support team directly.

You can also reach our team on the phone at 1-855-GET-WREN.

I am unable to connect my Wren V5US to my network.

Possible solutions:

1. Verify that your WiFi network is functioning.

2. The WiFi signal may be weak or the Wren V5US may be out of range of your WiFi network. Move the Wren V5US closer to your network access point.

3. Reset the Wren V5US Hardware:

  • Unplug the power supply from the rear of the speaker.
  • Wait 15 seconds, then plug in power supply and turn on the speaker.

4. Verify that you have selected the WiFi source on the speaker before trying to set up your network connection.

If you cannot troubleshoot your problem using these steps, please contact our technical support team.

The Play-Fi App cannot find the Play-Fi devices.

Possible solutions:

Verify that the following are true:

1. Play-Fi devices are fully powered on and in Discovery Mode.

2. You are within the recommended range of your router.

3. Your source device has its WiFi enabled.

4. There are no other source apps on your device that are currently running that are impeding WiFi connectivity.

  • If you still can’t find the Play-Fi device, and are in an office environment, verify with your network administrator that no special permissions are enabled that would prevent external wireless devices from broadcasting within the network.
  • If the speaker remains unfound, perform a factory reset on the offending unit, restart your source device and re-download the Play-Fi App.

If you cannot troubleshoot your problem using these steps, please contact our technical support team.

The Play-Fi App says “Play-Fi Devices Lost.”

Possible solutions:

If you see this message, it could mean one or more things:

  • The connection to your network is very weak
  • There is heavy network traffic.
  • You’ve moved out of your personal network’s coverage range.
  • You have lost your network connection.
  • You have connected to a network other than the one your Play-Fi device(s) are on.
  • Your source device’s WiFi has been taken over by another app.
  • Your device lost power in the middle of communication.

Make sure the following are true:

  • Verify that your network setting and that your devices are connected to the same network.
  • Ensure that your source device has not left the range of your router.
  • Verify that your source device is on the same network as your speakers.

Finally, exit and then restart the Play-Fi App. It should now find all of your devices.

If you are still unable to find the Play-Fi device(s), reset the speaker by unplugging and plugging it back in.

If you cannot troubleshoot your problem using these steps, please contact our technical support team.

DTS Play-Fi

Knowledge Base